请选择 进入手机版 | 继续访问电脑版

查看: 2160|回复: 0

[官方] Unity 2018.1脚本运行时更新

[复制链接]

1144

主题

1840

帖子

2万

贡献

管理员

Rank: 9Rank: 9Rank: 9

积分
24075
QQ
发表于 2018-4-9 03:24:18 | 显示全部楼层 |阅读模式
Unity 2018.1现在加入了得到完全支持的全新.NET运行时。随着.NET生态系统不断的发展,Unity将致力于保持与最新版.NET的功能兼容性。

03.png


开发历程
在Unity 2017.1中,我们发布了稳定的脚本运行时的第一个实验预览版。经过Unity 2017.2和Unity 2017.3的发布周期后,不少Unity用户已经使用这个实验性脚本运行时,并提供了宝贵的反馈。我们也和来自微软Mono团队和Visual Studio团队优秀开发者紧密合作。我们解决了各类问题,修正了多个错误,使得新版的脚本运行时变得越来越稳定。

02.png


随着Unity 2018.1的到来,我们认为是时候推动它的广泛使用了。如果你还没有尝试使用它,现在就进行尝试吧!

为什么使用
这个稳定的脚本运行时将为Unity带来了大量的新版C#和.NET的功能。这其中有:

  • C# 6
  • NET 4.7.1类库
  • 支持在.NET Standard 2.0和1.x构建的程序集
  • IL2CPP中的托管代码调试功能(在Unity 2018.1中仍处于实验阶段,仅用于独立播放器,它将在之后的新版本中得到完全支持)


.NET配置文件的选择
稳定的脚本运行时中有二个全新的.NET配置文件。对.NET类库而言,.NET配置文件能定义代码所能使用的底层API。你可以通过修改Player Settings中的“Api Compatibility Level”选项为播放器构建选择.NET配置文件。Unity支持的二个.NET配置文件如下:

  • .NET Standard 2.0
  • .NET 4.x.


.NET Standard 2.0 配置文件能匹配.NET 基金会发布的同名配置文件。对于Unity新项目来说,这将是一个不错的选择。这个配置文件比.NET 4.x小,我们推荐在一些有大小限制的平台上使用它,例如:移动端平台。除此之外,我们还会确保这个版本在所有Unity支持的平台使用。

01.png


.NET 4.x 配置文件能够使用最新版的.NET 4 API。这包括所有在.NET Framework类库中可用的代码。它还支持所有的.NET Standard 2.0 配置文件,所以它能应用于面向.NET Standard 2.0构建的托管插件程序集。尽管它能够使用较大范围的API,但该API的某些部分不适用于所有平台。如果你的项目需要.NET Standard中没出现的功能,或是包含遗留代码的功能,这会是个不错的选择。

未来展望
如今新版的脚本运行时已得到Unity的完全支持,我们将在未来版本的Unity中对它进行维护。我们正在给所有平台加入TLS 1.2支持,通过新版脚本运行时来对构建大小和构建时间进行改进。

在Unity 2018.1中,旧版的脚本运行时仍将作为新建项目时的默认设置。在Unity 2018.x发布周期中,我们将会把新建项目的默认脚本运行时改为稳定的脚本运行时。尽管旧版脚本运行时完全支持已有项目,我们还是会逐渐弃用旧版脚本运行时。

我们会移除旧版脚本运行时,把稳定的脚本运行时作为唯一的选项。我们建议用户开始向稳定的脚本运行时迁移。由于我们的精力将转移到稳定的脚本运行时,所以对于旧版脚本运行时,我们仅会进行错误修复工作。关于弃用过程和移除日程的额外说明将在不久后发布。

Unity为近来逐渐壮大的.NET生态系统的演变感到高兴。在.NET继续改进的过程中,我们将专注于给Unity开发者带来最新的.NET工具,例如C# 7,敬请关注我们的成果!
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表