请选择 进入手机版 | 继续访问电脑版

查看: 522|回复: 0

[iOS] Unity升级版本XCODE添加xlauncher,linking时报错

[复制链接]

1

主题

1

帖子

35

贡献

初级UU族—1级

Rank: 1

积分
35
发表于 2017-5-19 03:27:31 | 显示全部楼层 |阅读模式
原来是用Unity5.2.3,导出XCODE后添加Xlauncher sdk不会报错.
后来升级到Unity5.4.5,再按照同样的步骤去添加Xlauncher,在链接时报:
Undefined symbols for architecture arm64:
  "__ios91orNewer", referenced from:
      ____Z22IsStylusTouchSupportedv_block_invoke in libiPhone-lib.a(iPhoneInputImpl.o)
  "_UnityRequestQuit", referenced from:
      UnityPlayerLoopImpl(bool) in libiPhone-lib.a(LibEntryPoint.o)
ld: symbol(s) not found for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

我确认了Unity导出项目时Architecture选的是Universal,为了同时支持32和64位,libiPhone.a也是支持arm64的




您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表