请选择 进入手机版 | 继续访问电脑版

查看: 1103|回复: 7

(转)unity脚本错误“There are inconsistent line endings in ...”

[复制链接]

2

主题

2

帖子

35

贡献

初级UU族—1级

Rank: 1

积分
35
发表于 2017-4-13 07:57:32 | 显示全部楼层 |阅读模式
    今天在做场景切换,结果写好了切换脚本添加的时候报错了:“There are inconsistent line endings in ...”,百度了一下找到了一个比较好的解决办法,转载过来方便以后查找。本文转自:http://www.cnblogs.com/sevenyuan/archive/2012/12/06/2805114.html



情景描述:最近在做Unity的网络底层,用VS编写源码,MonoDevelop用来Debug,在Flash Builder上搭建的Python做协议生成器,期间有无数次Unity莫名奇妙的的down掉了,然后仔细分析了一下:

1、unity会爆出错误:

  There are inconsistent line endings in the 'Assets/...cs' script. Some are Mac OS X (UNIX) and some are Windows.

  This might lead to incorrect line numbers in stacktraces and compiler errors. Unitron and other text editors can fix this using Convert Line Endings menu commands.

2、monoDevelop在保存更改时也会报出编码错误:

  The file "E:\BillGameframe\unity\...Netmanager\Netmanager.cs" has line endings which differ from the policy settings.
  Do you want to convert the line endings?

3、然后用Notepad++的“显示所有字符” 查看文件,发现VS保存的文件每行以‘CRLF’结尾(window平台文件),而MonoDevelop保存的是‘LF’结尾(Unix平台)

4、然后用Unity新建c#文件,发现为‘LF’结尾(Unix平台)

  解决方案:

1、将unity新建文件改为‘CRLF’

  将:C:\Program Files\Unity\Editor\Data\Resources\ScriptTemplates\下4个unity新建文件的模板改为‘CRLF’,

  修改方法:用VS打开,在文件-高级保存选项-行尾 选择window(CRLF);

   2012120615164535.png

2、修改MonoDevelop环境编码:

  修改方法:Project-Solution Option-Source Code-Code Formatting- 下3个文件格式的Line endings都改为Windows

   2012120615222350.png
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表